Screen Removal Bargman L-300 Door Handle brakes Satellite Fuel Tank Fire Extinguishers Roof Antenna Tech Talk Forum Shortcut Motor Oil Window Generators headlights batteries Radiator AC Unit Grab Handle Wiper Blades Wiper Blades Door Locks Door Locks Door Locks Door Locks Rims Front Shocks Rear Shocks Front Tires Oil Filter Steps Roof Vent Awning Propane Tank Mirror Info Clearance Lights Clearance Lights Clearance Lights Clearance Lights Clearance Lights Spartan Chassis Gillig Chassis Freightliner Chassis P-32 Chassis MCC Chassis
    Forums    Tech Talk    Engine wont start
Go to...
Start A New Topic
Search
Notify
Tools
Reply To This Topic
  
Engine wont start
 Login now/Join our community
 
posted
My 2001 Tradewinds with 5.9 cummins was in the shop to have a roof mounted AC replaced. When I went to pick it up the engine batteries were dead. After charging the batteries it would not crank. Also the transmission indicator light was not lit up.

We determined that the electric lift pump was not working so we replaced it. When bleeding the lines the transmission indicator light was back on and we were able to get it cranked.

After two minutes it stopped running. The transmission indicator light is off again and there is no power to the lift pump. Does anybody have any thoughts? The batteries were fairly new so I'm wondering if something related to the AC could have shorted out a relay or the ECU?
 
Posts: 2 | Location: Montgomery, AL | Member Since: 10-19-2023Reply With QuoteReport This Post
Supporting Member of Barthmobile.com 8/11
Picture of billyt53
posted Hide Post
quote:
This

Good morning, the Allison has both battery fuses and ignition fuses, check those. Secondly, the T M used in those days have a plug-in e-prom, in cold weather we had ours do the same thing, we lucked out and after it warmed up the panel lit up and we were able to get going, but it only allowed that two more times and we had to replace the TCM. The neutral start circuit runs through the Allison VIM so no power no crank. Good luck


Billy & Helen Thibodeaux

Retired from Billy Thibodeaux's Premiere RV, Inc. Scott, LA 70583 I-10 Exit 97
The Farm is near Duson, LA I-10 Exit 92 then N 1 mile on right
Three Full 50 Amp RV Hookups !
billynhelen@me.com
Data Tag: 9404-3908-36XI-2C
1994 Sovereign 36' Widebody on Spartan IC (Mountain Master Lite) Chassis.
Powered by Cummins ISL9-450
Onan 8,000 Quiet Diesel Genset
Toad: 2018 Chevy Colorado ZR2 Diesel with M&G Car Brake
 
Posts: 376 | Location: 1mile north of I-10 Exit 92, Duson, LA USA in The Heart of CAJUN COUNRTY ! ! ! | Member Since: 05-14-2005Reply With QuoteReport This Post
posted Hide Post
Thank you! I will check on both
 
Posts: 2 | Location: Montgomery, AL | Member Since: 10-19-2023Reply With QuoteReport This Post
Supporting Member of Barthmobile.com 6/19
Picture of Harold,Cat&Sam
posted Hide Post
Check your battery connections and the power to the Allison controller . Our 1994 coach with the Allison 3060 had a 10 gauge hot wire running from the Allison relay box straight to the batteries . It must be hot for the Allison panel to light up and the engine to start .

Also have your batteries checked . Sometimes when they go completely dead it damages them . A bad cell in one battery can cause problems .

Good luck with the troubleshooting .


Harold
Cat
Sam Miniature Schnauzer
3.8.2009 - 9.24.2021

93 30ft Breakaway
9209-3823-30BS-11B

KE5WCW
 
Posts: 626 | Location: Mooringsport,LA | Member Since: 05-30-2019Reply With QuoteReport This Post
  Powered by Social Strata  
 

    Forums    Tech Talk    Engine wont start

This website is dedicated to the Barth Custom Coach, their owners and those who admire this American made, quality crafted, motor coach.
We are committed to the history, preservation and restoration of the Barth Custom Coach.