Screen Removal Bargman L-300 Door Handle brakes Satellite Fuel Tank Fire Extinguishers Roof Antenna Tech Talk Forum Shortcut Motor Oil Window Generators headlights batteries Radiator AC Unit Grab Handle Wiper Blades Wiper Blades Door Locks Door Locks Door Locks Door Locks Rims Front Shocks Rear Shocks Front Tires Oil Filter Steps Roof Vent Awning Propane Tank Mirror Info Clearance Lights Clearance Lights Clearance Lights Clearance Lights Clearance Lights Spartan Chassis Gillig Chassis Freightliner Chassis P-32 Chassis MCC Chassis
    Forums    Tech Talk    Intermittent hot water heater
Go to...
Start A New Topic
Search
Notify
Tools
Reply To This Topic
  
Intermittent hot water heater
 Login now/Join our community
 
Supporting Member of Barthmobile.com 6/17
Picture of Richard_Muise
posted
Our Atwood water heater sometime works, sometimes doesn't. I cleaned all the connectors to no avail. Could the board be going bad?


R.P.Muise 1994 Breakaway/Cummins 5.9/Allison transmission/Spartan Chassis
 
Posts: 549 | Location: Springfield, Massachusetts | Member Since: 10-13-2005Reply With QuoteReport This Post
Supporting Member of Barthmobile.com 12/10
Picture of ccctimtation
posted Hide Post
We have the same problem but have an electric blanket heater so when the gas isn't working showers get shorter and more military. It is probably the board but I haven't given up contact cleaning and acting like I give it love. Boards are expensive and if they aren't the solution you now have two solutions to an unsolved problem. If we didn't have the electric option we would probably spend the money for a board or a tech with recommendations, try to find that person!


I was taught to respect my elders but it is getting harder to find them!
 
Posts: 727 | Location: St. Charles, MO, USA | Member Since: 10-09-2003Reply With QuoteReport This Post
Supporting Member of Barthmobile.com 3/11
Picture of Tom  and Julie
posted Hide Post
What board? Mine has an electric element and the motor coolant hoses with a screw in temp sensor to turn on and off. If you have propane then the temp sensor controls a relay to light the gas. May be the heater has calcium residue inside the tank hindering the heating element. All electrical heaters should be flushed about every two years after filling with vinegar or a commercial cleaner, that is vinegar.


1993 32' Regency Wide Body, 4 speed Allison Trans, Front Entry door, Diamond Plate aluminum roof &
1981 Euro 22' w Chevy 350 engine and TH 400 tranny
 
Posts: 1368 | Location: Houston Texas | Member Since: 12-19-2006Reply With QuoteReport This Post
Supporting Member of Barthmobile.com 2/16
Captain Doom
Picture of Rusty
posted Hide Post
quote:
Originally posted by Richard_Muise:
Our Atwood water heater sometime works, sometimes doesn't. I cleaned all the connectors to no avail. Could the board be going bad?


On propane or electric? It could be the control board, but I'd pull the burner and clean it.


Rusty


MilSpec AMG 6.5L TD 230HP; built-to-order by Peninsular Engines:  Hi-pop injectors, gear-driven camshaft, non-waste-gated, high-output turbo, 18:1 pistons.  Fuel economy increased by 15-20%, power, WOW!"StaRV II"

'94 28' Breakaway: MilSpec AMG 6.5L TD 230HP

Nelson and Chester, not-spoiled Golden Retrievers

Sometimes I think we're alone in the universe, and sometimes I think we're not.
In either case the idea is quite staggering.
- Arthur C. Clarke

It was a woman who drove me to drink, and I've been searching thirty years to find her and thank her - W. C. Fields
 
Posts: 8201 | Location: Brooker, FL, USA | Member Since: 09-08-2005Reply With QuoteReport This Post
Supporting Member of Barthmobile.com 7/17
Picture of Steve VW
posted Hide Post
First advice; Be sure you are getting 12VDC and ground to the module. Clean/replace all electrical connectors you can find. Gas Valve, flame sensor, ignitor, two tank mounted thermostats (normal one about 140 degrees, high temp safety one about 200 degrees) and the plugs on the module. You just fixed most of the problems.

The heater runs in stages. You turn the power on. A few seconds later the module turns on power to the gas valve. If the thermostat calls for heat the gas valve will open. The module will also fire the spark ignitor repeatedly, which should ignite the flame.

If the module detects a flame, it will quit firing the ignitor and leave the gas valve open until the thermostat quits calling for heat or the overtemp safety switch trips off. Then the gas valve closes.

If the module detects no flame, it will shut off the gas, then either repeat the ignitor cycle or quit trying.

So, if power is turned on and the thermostat calls for heat, the module should feed power through both thermostats to the gas valve and it should click on. (You can apply external power to test the gas valve coil, listen for the click)

If no power from module it is bad. Assuming gas turns on, watch for ignitor function. Some modules have a flasher light on the board that indicates when ignitor should be firing. The ignitor is just a spark plug. If no spark be sure the wire lead is connected and clear of grounds. Be sure the electrode gap and alignment are correct. No spark is a common module failure mode.

If flame lights, check flame shape and quality. Be sure the burner air flue is clear. (Spiders love this area) Be sure the heat exchangers and flue are clear.

If valve soon closes and flame dies, check flame sensor. Some are the old thermocouple style, newer ones may be IR heat sensors.

If you measure resistance both the normal thermostat and the high temp safety thermostat should be normally closed.

The gas valve should show a few ohms coil resistance. Opens indicate bad component.

Good luck Mechanic


8607-3346-33TFPOB------9708-M0037-37MM-01
86 Regal SE 33 Tag axle--"98" Monarch 37
Chev P3(7) 454TBI--------Cummins 8.3 300 hp
400 hp fuel injected-------6 spd Allison, Spartan MM
 
Posts: 3230 | Location: Kalkaska, MI | Member Since: 02-04-2011Reply With QuoteReport This Post
Supporting Member of Barthmobile.com 6/17
Picture of Richard_Muise
posted Hide Post
When it malfunctions nothing happens. No spark, nothing. I will recheck all the connections.


R.P.Muise 1994 Breakaway/Cummins 5.9/Allison transmission/Spartan Chassis
 
Posts: 549 | Location: Springfield, Massachusetts | Member Since: 10-13-2005Reply With QuoteReport This Post
  Powered by Social Strata  
 

    Forums    Tech Talk    Intermittent hot water heater

This website is dedicated to the Barth Custom Coach, their owners and those who admire this American made, quality crafted, motor coach.
We are committed to the history, preservation and restoration of the Barth Custom Coach.