Barthmobile Portal
Chrysler Laser cluster- odometer fail

This topic can be found at:
http://www.barthmobile.com/eve/forums/a/tpc/f/3431087061/m/5043993097

08-25-2017, 11:26 AM
benebob
Chrysler Laser cluster- odometer fail
My 86 Regal came with an electronic cluster out of a 84-86 Laser. I had an electrical issue that resulted in the odo failing on our last trip (well it lost some of its memory is what I'm told). The result is the odo simply goes to -----. After a bit of research this isn't an uncommon thing for early Chrysler odos as they can do this anytime power to the dash goes away but there is still power to the engine. Of course getting a cluster from a Laser isn't really a good option plus the miles would be different and you would need to find someone able to program it.

I stumbled upon this thread: http://www.turbododge.com/foru...ted.html#post2367897 as I need the odo working for inspection or it becomes a TMU vehicle which is less important to me then having an odo working for maint. etc. Well I pulled my chip and sent it to get looked at and he was able to not only pull my last miles (added 500 or so for the distance traveled since) fixed it and sent me an upgraded one. No charge as it is his second test chip he has done but he will be getting some beer tokens shortly. Odo lit right back up with my miles today and I also have a spare chip now. For those with the same cluster keep this thread in the back of your mind as to a probably fix if your odo stops working!
08-25-2017, 02:31 PM
Steve VW
Good news for those with orphan panels. Good thread title for search finds, too. Thanks for the info! Thumbs Up


8607-3346-33TFPOB------9708-M0037-37MM-01
86 Regal SE 33 Tag axle--"98" Monarch 37
Chev P3(7) 454TBI--------Cummins 8.3 300 hp
400 hp fuel injected-------6 spd Allison, Spartan MM